Wed, 19 Jan 2022 02:11:36 UTC

Information for RPM libpmem-devel-1.9.2-1.module_el8.5.0+756+4cdc1762.ppc64le.rpm

ID304529
Namelibpmem-devel
Version1.9.2
Release1.module_el8.5.0+756+4cdc1762
Epoch
Archppc64le
SummaryDevelopment files for the low-level persistent memory library
DescriptionThe libpmem provides low level persistent memory support. In particular, support for the persistent memory instructions for flushing changes to pmem is provided. This library is provided for software which tracks every store to pmem and needs to flush those changes to durability. Most developers will find higher level libraries like libpmemobj to be much more convenient.
Build Time2021-04-07 21:15:44 GMT
Size52066
331bd01c3f0506123d6c59c165d9b33a
LicenseBSD
Buildrootmodule-pmdk-1-fileformat-v6-8050020210407181047-b4937e53-build-68443-19374
Provides
libpmem-devel = 1.9.2-1.module_el8.5.0+756+4cdc1762
libpmem-devel(ppc-64) = 1.9.2-1.module_el8.5.0+756+4cdc1762
pkgconfig(libpmem) = 1.9.2
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
/usr/bin/pkg-config
libpmem = 1.9.2-1.module_el8.5.0+756+4cdc1762
libpmem.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 33 of 33
Name ascending sort Size
/usr/include/libpmem.h3829
/usr/lib64/libpmem.so12
/usr/lib64/pkgconfig/libpmem.pc268
/usr/share/doc/libpmem-devel0
/usr/share/doc/libpmem-devel/CONTRIBUTING.md6479
/usr/share/doc/libpmem-devel/ChangeLog36488
/usr/share/doc/libpmem-devel/README.md15938
/usr/share/licenses/libpmem-devel0
/usr/share/licenses/libpmem-devel/LICENSE1915
/usr/share/man/man3/pmem_check_version.3.gz39
/usr/share/man/man3/pmem_deep_drain.3.gz37
/usr/share/man/man3/pmem_deep_flush.3.gz37
/usr/share/man/man3/pmem_deep_persist.3.gz37
/usr/share/man/man3/pmem_drain.3.gz37
/usr/share/man/man3/pmem_errormsg.3.gz39
/usr/share/man/man3/pmem_flush.3.gz2610
/usr/share/man/man3/pmem_has_auto_flush.3.gz37
/usr/share/man/man3/pmem_has_hw_drain.3.gz37
/usr/share/man/man3/pmem_is_pmem.3.gz2647
/usr/share/man/man3/pmem_map_file.3.gz36
/usr/share/man/man3/pmem_memcpy.3.gz45
/usr/share/man/man3/pmem_memcpy_nodrain.3.gz45
/usr/share/man/man3/pmem_memcpy_persist.3.gz45
/usr/share/man/man3/pmem_memmove.3.gz45
/usr/share/man/man3/pmem_memmove_nodrain.3.gz45
/usr/share/man/man3/pmem_memmove_persist.3.gz2077
/usr/share/man/man3/pmem_memset.3.gz45
/usr/share/man/man3/pmem_memset_nodrain.3.gz45
/usr/share/man/man3/pmem_memset_persist.3.gz45
/usr/share/man/man3/pmem_msync.3.gz37
/usr/share/man/man3/pmem_persist.3.gz37
/usr/share/man/man3/pmem_unmap.3.gz36
/usr/share/man/man7/libpmem.7.gz4914
Component of No Buildroots