Fri, 04 Dec 2020 09:08:33 UTC

Information for build libmodulemd-2.5.0-4.el8_1

ID6115
Package Namelibmodulemd
Version2.5.0
Release4.el8_1
Epoch
Sourcegit+https://git.centos.org/rpms/libmodulemd.git#1d19c0ebf028521dd8895b235c8f9790e6c7c352
SummaryModule metadata manipulation library
DescriptionC Library for manipulating module metadata files. See https://github.com/fedora-modularity/libmodulemd/blob/master/README.md for more details.
Built bybstinson
State complete
Volume DEFAULT
StartedWed, 11 Dec 2019 19:33:10 UTC
CompletedWed, 11 Dec 2019 19:40:18 UTC
Taskbuild (dist-c8_1-updates, /rpms/libmodulemd.git:1d19c0ebf028521dd8895b235c8f9790e6c7c352)
Extra{'source': {'original_url': 'git+https://git.centos.org/rpms/libmodulemd.git?#1d19c0ebf028521dd8895b235c8f9790e6c7c352'}}
Tags
dist-c8-compose
dist-c8-stream
dist-c8-stream-compose
dist-c8-tycho-bootstrap
dist-c8-updates
RPMs
src
libmodulemd-2.5.0-4.el8_1.src.rpm (info) (download)
aarch64
libmodulemd-2.5.0-4.el8_1.aarch64.rpm (info) (download)
libmodulemd-devel-2.5.0-4.el8_1.aarch64.rpm (info) (download)
libmodulemd1-1.8.11-4.el8_1.aarch64.rpm (info) (download)
libmodulemd1-devel-1.8.11-4.el8_1.aarch64.rpm (info) (download)
python3-libmodulemd-2.5.0-4.el8_1.aarch64.rpm (info) (download)
python3-libmodulemd1-1.8.11-4.el8_1.aarch64.rpm (info) (download)
libmodulemd-debuginfo-2.5.0-4.el8_1.aarch64.rpm (info) (download)
libmodulemd-debugsource-2.5.0-4.el8_1.aarch64.rpm (info) (download)
libmodulemd1-debuginfo-1.8.11-4.el8_1.aarch64.rpm (info) (download)
i686
libmodulemd-2.5.0-4.el8_1.i686.rpm (info) (download)
libmodulemd-devel-2.5.0-4.el8_1.i686.rpm (info) (download)
libmodulemd1-1.8.11-4.el8_1.i686.rpm (info) (download)
libmodulemd1-devel-1.8.11-4.el8_1.i686.rpm (info) (download)
python3-libmodulemd-2.5.0-4.el8_1.i686.rpm (info) (download)
python3-libmodulemd1-1.8.11-4.el8_1.i686.rpm (info) (download)
libmodulemd-debuginfo-2.5.0-4.el8_1.i686.rpm (info) (download)
libmodulemd-debugsource-2.5.0-4.el8_1.i686.rpm (info) (download)
libmodulemd1-debuginfo-1.8.11-4.el8_1.i686.rpm (info) (download)
ppc64le
libmodulemd-2.5.0-4.el8_1.ppc64le.rpm (info) (download)
libmodulemd-devel-2.5.0-4.el8_1.ppc64le.rpm (info) (download)
libmodulemd1-1.8.11-4.el8_1.ppc64le.rpm (info) (download)
libmodulemd1-devel-1.8.11-4.el8_1.ppc64le.rpm (info) (download)
python3-libmodulemd-2.5.0-4.el8_1.ppc64le.rpm (info) (download)
python3-libmodulemd1-1.8.11-4.el8_1.ppc64le.rpm (info) (download)
libmodulemd-debuginfo-2.5.0-4.el8_1.ppc64le.rpm (info) (download)
libmodulemd-debugsource-2.5.0-4.el8_1.ppc64le.rpm (info) (download)
libmodulemd1-debuginfo-1.8.11-4.el8_1.ppc64le.rpm (info) (download)
x86_64
libmodulemd-2.5.0-4.el8_1.x86_64.rpm (info) (download)
libmodulemd-devel-2.5.0-4.el8_1.x86_64.rpm (info) (download)
libmodulemd1-1.8.11-4.el8_1.x86_64.rpm (info) (download)
libmodulemd1-devel-1.8.11-4.el8_1.x86_64.rpm (info) (download)
python3-libmodulemd-2.5.0-4.el8_1.x86_64.rpm (info) (download)
python3-libmodulemd1-1.8.11-4.el8_1.x86_64.rpm (info) (download)
libmodulemd-debuginfo-2.5.0-4.el8_1.x86_64.rpm (info) (download)
libmodulemd-debugsource-2.5.0-4.el8_1.x86_64.rpm (info) (download)
libmodulemd1-debuginfo-1.8.11-4.el8_1.x86_64.rpm (info) (download)
Logs
aarch64
state.log
hw_info.log
root.log
build.log
mock_output.log
x86_64
state.log
hw_info.log
root.log
build.log
mock_output.log
ppc64le
state.log
hw_info.log
root.log
build.log
mock_output.log
i686
state.log
hw_info.log
root.log
build.log
mock_output.log
Changelog * Wed Oct 23 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.5.0-4 - Improve default merging logic when dealing with third-party repos - Resolves: rhbz#1763779 * Wed May 29 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.5.0-2 - Fix memory corruption error using Module.search_rpms() from python - Speed up valgrind tests - Resolves: rhbz#1714766 * Wed May 22 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.5.0-1 - Rebase to 2.5.0 and 1.8.11 - Related: rhbz#1693680 * Mon May 13 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.4.0-1 - Rebase to 2.4.0 and 1.8.10 - Resolves: rhbz#1693680 * Fri Jan 18 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-5 - Don't fail merges when default streams differ - Resolves: rhbz#1666871 * Wed Jan 16 2019 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-4 - Include modified value when copying Defaults objects - Resolves: rhbz#1665465 * Thu Dec 13 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-3 - Keep libmodulemd1 in sync with libmodulemd * Thu Dec 13 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-2 - Fix package location of modulemd-validator * Thu Dec 13 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-1 - Update to 2.0.0 final - Assorted fixes for validation - Add modulemd-validator tool based on v2 code - Fix a crash when merging defaults - Add missing BuildRequires * Tue Dec 11 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-0.beta2 - Update to 2.0.0beta2 - Better validation of stored content during read and write operations - ModuleIndex now returns FALSE if any subdocument fails - Fix tests on 32-bit platforms - Make unknown keys in YAML maps non-fatal for libmodulemd1 - Make unknown keys in YAML maps optionally fatal for libmodulemd 2.x - Fix RPM version requirements for libmodulemd1 * Mon Dec 10 2018 Stephen Gallagher <sgallagh@redhat.com> - 2.0.0-0.beta1 - Total rewrite to 2.0 API - Resolves: rhbz#1646436 * Thu Aug 09 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.6.2-2 - Fix backwards-incompatible API change - Resolves: rhbz#1607083 * Tue Aug 07 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.6.2-1 - Update to 1.6.2 - Make buildorder a signed integer to match modulemd specification - Obsolete unsupported pythonX-modulemd packages * Fri Aug 03 2018 Florian Weimer <fweimer@redhat.com> - 1.6.1-2 - Honor %{valgrind_arches} * Fri Jul 20 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.6.1-1 - Update to 1.6.1 - Fix header include ordering - Suppress empty sections from .dump() ordering * Wed Jul 18 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.6.0-1 - Update to 1.6.0 - Adds Modulemd.ModuleStream object, deprecating Modulemd.Module - Adds Modulemd.Translation and Modulemd.TranslationEntry objects - Adds Modulemd.ImprovedModule object that collects streams, defaults and translations together - Adds new Modulemd.index_from_*() funtions to get a hash table of Modulemd.ImprovedModule objects for easier searching - Moves function documentation to the public headers - Corrects the license headers to MIT (they were incorrectly listed as MITNFA in previous releases) - Makes the "eol" field optional for Modulemd.ServiceLevel - Clean up HTML documentation - Fixes a type error on 32-bit systems * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.2-2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild * Sat Jun 23 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.5.2-1 - Update to libdmodulemd 1.5.2 - Don't free uninitialized memory * Fri Jun 22 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.5.1-2 - Fix buildopts property not being initialized * Tue Jun 19 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.5.1-1 - Update to version 1.5.1 - Re-enable build-time tests * Mon Jun 18 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.5.0-2 - Temporarily disable build-time tests * Mon Jun 18 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.5.0-1 - Update to version 1.5.0 - Adds support for "intents" in Modulemd.Defaults - Adds `Modulemd.get_version()` - Adds support for RPM whitelists in the buildopts - Adds a new object: Modulemd.Buildopts - Deprecates Modulemd.Module.get_rpm_buildopts() - Deprecates Modulemd.Module.set_rpm_buildopts() - Fixes some missing license blurbs * Tue May 08 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.4.1-1 - Update to version 1.4.1 - Improve output from modulemd-validator - Drop upstreamed patches * Wed Apr 25 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.4.0-2 - Fix pointer math error - Fix compilation failure in Fedora build system * Wed Apr 25 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.4.0-1 - Update to version 1.4.0 - Adds new API for returning failed YAML subdocuments - Stop emitting log messages by default (polluting consumer logs) - Validate RPM artifacts for proper NEVRA format - Improve the validator tool - Drop upstreamed patch * Mon Apr 16 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.3.0-2 - Fix serious error in modulemd-defaults emitter * Fri Apr 13 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.3.0-1 - Update to version 1.3.0 - New Public Objects: * Modulemd.Prioritizer - tool to merge module defaults - New Public Functions: * Modulemd.SimpleSet.is_equal() * Modulemd.Defaults.copy() * Modulemd.Defaults.merge() * Wed Apr 04 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.2.0-1 - Update to version 1.2.0 - New Functions: * Modulemd.objects_from_file() * Modulemd.objects_from_string() * Modulemd.dump() * Modulemd.dumps() * Modulemd.Defaults.new_from_file() * Modulemd.Defaults.new_from_string() - Deprecated Functions: * Modulemd.Module.new_all_from_file() * Modulemd.Module.new_all_from_file_ext() * Modulemd.Module.new_all_from_string() * Modulemd.Module.new_all_from_string_ext() * Modulemd.Module.dump_all() * Modulemd.Module.dumps_all() - Bugfixes * Properly use G_BEGIN_DECLS and G_END_DECLS in headers * Assorted fixes for memory ownership in GObject Introspection * Fri Mar 23 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2 - Fix missing G_END_DECL from public headers * Mon Mar 19 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1 - Fix numerous memory leaks - Drop upstreamed patch * Thu Mar 15 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.1.2-1 - Update to version 1.1.2 - Revert backwards-incompatible API change - Fix version string in pkgconfig file * Thu Mar 15 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.1.1-1 - Update to version 1.1.1 - Make default stream and profiles optional - Fixes: https://github.com/fedora-modularity/libmodulemd/issues/25 - Fixes: https://github.com/fedora-modularity/libmodulemd/issues/26 - Fixes: https://github.com/fedora-modularity/libmodulemd/issues/27 * Wed Mar 14 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.1.0-1 - Update to version 1.1.0 - Adds support for handling modulemd-defaults YAML documents - Adds peek()/dup() routines to all object properties - Adds Modulemd.Module.dup_nsvc() to retrieve the canonical form of the unique module identifier. - Adds support for boolean types in the XMD section - Revert obsoletion of pythonX-modulemd packages for now * Tue Mar 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.4-2 - Obsolete unsupported pythonX-modulemd packages * Tue Feb 27 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.0.4-1 - Update to 1.0.4 - Rework version autodetection - Avoid infinite loop on unparseable YAML * Sun Feb 25 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.0.3-1 - RPM components are properly emitted when no module components exist - Parser works around late determination of modulemd version * Fri Feb 16 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.0.2-1 - Be more strict with certain parser edge-cases - Replace popt argument processing with glib - Drop upstreamed patches * Thu Feb 15 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.0.1-2 - Handle certain unlikely format violations * Thu Feb 15 2018 Stephen Gallagher <sgallagh@redhat.com> - 1.0.1-1 - Support modulemd v2 - Add tool to do quick validation of modulemd - Fix memory management - Warn and ignore unparseable sub-documents in the YAML - Fix several memory issues detected by Coverity scan * Tue Feb 06 2018 Stephen Gallagher <sgallagh@redhat.com> - 0.2.2-1 - Update to libmodulemd 0.2.2 - Fix numerous minor memory leaks - Fix issues with EOL/SL dates * Tue Feb 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-3 - Own appropriate directories * Fri Feb 02 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-2 - Switch to %ldconfig_scriptlets * Fri Jan 05 2018 Stephen Gallagher <sgallagh@redhat.com> - 0.2.1-1 - Update to libmodulemd 0.2.1 - Add 'name' property for Profiles * Thu Oct 05 2017 Stephen Gallagher <sgallagh@redhat.com> - 0.2.0-2 - Add missing BuildRequires for gtk-doc * Thu Oct 05 2017 Stephen Gallagher <sgallagh@redhat.com> - 0.2.0-1 - Update to libmodulemd 0.2.0 - Adds gtk-doc generated documentation - (ABI-break) Makes all optional properties accept NULL as a value to clear them - (ABI-break) Modulemd.SimpleSet takes a STRV (char **) instead of a GLib.PtrArray - Fixes a bug where the name was not always set for components - Adds support for dumping YAML from the introspected API - Includes add/remove routines for profiles * Sat Sep 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.0-5 - Use %_isa in Requires for main package from devel * Mon Sep 18 2017 Stephen Gallagher <sgallagh@redhat.com> - 0.1.0-4 - Correct the license to MIT * Mon Sep 18 2017 Stephen Gallagher <sgallagh@redhat.com> - 0.1.0-3 - Modifications requested during package review * Fri Sep 15 2017 Stephen Gallagher <sgallagh@redhat.com> - 0.1.0-2 - First public release