Sun, 26 Sep 2021 04:58:40 UTC

Information for RPM perl-Module-Build-2:0.42.24-5.module_el8.1.0+224+75158c84.src.rpm

ID92193
Nameperl-Module-Build
Version0.42.24
Release5.module_el8.1.0+224+75158c84
Epoch2
Archsrc
SummaryBuild and install Perl modules
DescriptionModule::Build is a system for building, testing, and installing Perl modules. It is meant to be an alternative to ExtUtils::MakeMaker. Developers may alter the behavior of the module through sub-classing in a much more straightforward way than with MakeMaker. It also does not require a make on your system - most of the Module::Build code is pure-perl and written in a very cross-platform way. In fact, you don't even need a shell, so even platforms like MacOS (traditional) can use it fairly easily. Its only prerequisites are modules that are included with perl 5.6.0, and it works fine on perl 5.005 if you can install a few additional modules.
Build Time2019-11-18 23:47:36 GMT
Size322751
552693a7f1cf4a7167e9105bd6d8ada5
LicenseGPL+ or Artistic
Buildrootmodule-perl-bootstrap-5.24-8010020190625031225-0ebb7e5b-build-28825-2828
Provides No Provides
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
coreutils
perl(Archive::Tar)
perl(AutoSplit)
perl(CPAN::Meta) >= 2.142060
perl(CPAN::Meta::Converter) >= 2.141170
perl(CPAN::Meta::Merge)
perl(CPAN::Meta::YAML) >= 0.003
perl(Carp)
perl(Config)
perl(Cwd)
perl(Data::Dumper)
perl(DynaLoader)
perl(Exporter)
perl(ExtUtils::CBuilder) >= 0.27
perl(ExtUtils::Install) >= 0.3
perl(ExtUtils::Installed)
perl(ExtUtils::Manifest) >= 1.54
perl(ExtUtils::Mkbootstrap)
perl(ExtUtils::Packlist)
perl(ExtUtils::ParseXS) >= 2.21
perl(File::Basename)
perl(File::Compare)
perl(File::Copy)
perl(File::Find)
perl(File::Path)
perl(File::Spec) >= 0.82
perl(File::Spec::Functions)
perl(File::Temp) >= 0.15
perl(Getopt::Long)
perl(Module::Metadata) >= 1.000002
perl(Parse::CPAN::Meta) >= 1.4401
perl(Perl::OSType) >= 1
perl(TAP::Harness)
perl(TAP::Harness::Env)
perl(Test::Harness) >= 3.29
perl(Test::More) >= 0.49
perl(Text::ParseWords)
perl(base)
perl(inc::latest)
perl(lib)
perl(strict)
perl(utf8)
perl(vars)
perl(version) >= 0.87
perl(warnings)
perl-devel
perl-generators
perl-interpreter
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 2 of 2
Name ascending sort Size
Module-Build-0.4224.tar.gz304181
perl-Module-Build.spec12569
Component of No Buildroots