Wed, 01 Dec 2021 16:56:50 UTC

Information for RPM libffi-3.1-21.el8.x86_64.rpm

ID80397
Namelibffi
Version3.1
Release21.el8
Epoch
Archx86_64
SummaryA portable foreign function interface library
DescriptionCompilers for high level languages generate code that follow certain conventions. These conventions are necessary, in part, for separate compilation to work. One such convention is the "calling convention". The calling convention is a set of assumptions made by the compiler about where function arguments will be found on entry to a function. A calling convention also specifies where the return value for a function is found. Some programs may not know at the time of compilation what arguments are to be passed to a function. For instance, an interpreter may be told at run-time about the number and types of arguments used to call a given function. `Libffi' can be used in such programs to provide a bridge from the interpreter program to compiled code. The `libffi' library provides a portable, high level programming interface to various calling conventions. This allows a programmer to call any function specified by a call interface description at run time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language. The `libffi' library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. A layer must exist above `libffi' that handles type conversions for values passed between the two languages.
Build Time2019-11-08 19:00:26 GMT
Size37072
75f0d6ae08ec69f1d9c600ce05bfad37
LicenseMIT
Buildrootdist-c8-build-26592-2214
Provides
libffi = 3.1-21.el8
libffi(x86-64) = 3.1-21.el8
libffi.so.6()(64bit)
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
libc.so.6()(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.7)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 9 of 9
Name ascending sort Size
/usr/lib/.build-id0
/usr/lib/.build-id/6a0
/usr/lib/.build-id/6a/a4af1be0871bc681a237eba12db42e5107c3f137
/usr/lib64/libffi.so.615
/usr/lib64/libffi.so.6.0.251808
/usr/share/doc/libffi0
/usr/share/doc/libffi/README15464
/usr/share/licenses/libffi0
/usr/share/licenses/libffi/LICENSE1132
Component of
Page:
1 through 50 of 1602 >>>
Buildroot descending sort Created State
dist-c8-build-59042-14350 2020-11-12 20:18:07 expired
dist-c8-build-59039-12324 2020-11-12 19:52:41 expired
dist-c8-build-59020-12324 2020-11-12 13:10:26 expired
dist-c8-build-58991-12324 2020-11-11 22:27:53 expired
dist-c8-build-58990-12324 2020-11-11 22:27:52 expired
dist-c8-build-58980-12324 2020-11-11 21:41:01 expired
dist-c8-build-58978-12324 2020-11-11 21:41:00 expired
dist-c8-build-58973-12324 2020-11-11 20:26:43 expired
dist-c8-build-58972-12324 2020-11-11 20:26:42 expired
dist-c8-build-58968-12324 2020-11-11 19:03:44 expired
dist-c8-build-58967-12324 2020-11-11 19:03:43 expired
dist-c8-build-58641-12324 2020-11-06 18:09:38 expired
dist-c8-build-58640-12324 2020-11-06 18:09:36 expired
dist-c8-build-58620-12324 2020-11-06 17:22:22 expired
dist-c8-build-58619-12324 2020-11-06 17:22:20 expired
dist-c8-build-58600-12324 2020-11-06 15:12:19 expired
dist-c8-build-58599-12324 2020-11-06 15:12:17 expired
dist-c8-build-58593-12324 2020-11-06 01:52:46 expired
dist-c8-build-58592-12324 2020-11-06 01:52:42 expired
dist-c8-build-58586-12324 2020-11-05 21:55:47 expired
dist-c8-build-58583-12324 2020-11-05 21:55:45 expired
dist-c8-updates-build-58177-13738 2020-11-03 16:36:49 expired
dist-c8-updates-build-58174-13738 2020-11-03 16:35:25 expired
dist-c8-updates-build-58168-13719 2020-11-03 16:34:33 expired
dist-c8-updates-build-58164-13719 2020-11-03 16:33:56 expired
dist-c8-updates-build-58157-13719 2020-11-03 16:31:27 expired
dist-c8-updates-build-58153-13719 2020-11-03 16:30:20 expired
dist-c8-updates-build-58151-13719 2020-11-03 16:30:03 expired
dist-c8-updates-build-58149-13719 2020-11-03 16:30:02 expired
dist-c8-updates-build-58145-13719 2020-11-03 16:29:43 expired
dist-c8-updates-build-58143-13719 2020-11-03 16:29:27 expired
dist-c8-updates-build-58139-13706 2020-11-03 16:23:53 expired
dist-c8-updates-build-58133-13684 2020-11-03 16:20:48 expired
dist-c8-updates-build-58129-13684 2020-11-03 16:17:26 expired
dist-c8-updates-build-58125-13684 2020-11-03 16:15:48 expired
dist-c8-updates-build-58120-13684 2020-11-03 16:14:59 expired
dist-c8-updates-build-58118-13684 2020-11-03 16:14:40 expired
dist-c8-updates-build-58114-13668 2020-11-03 15:23:52 expired
dist-c8-updates-build-58109-13668 2020-11-03 15:22:11 expired
dist-c8-updates-build-58106-13668 2020-11-03 15:20:52 expired
dist-c8-updates-build-58104-13614 2020-11-03 15:01:59 expired
dist-c8_2-updates-build-58035-13505 2020-10-30 04:14:48 expired
dist-c8_2-updates-build-58030-13505 2020-10-30 04:14:18 expired
dist-c8_2-updates-build-58025-13505 2020-10-30 04:12:53 expired
dist-c8-build-58023-12324 2020-10-30 01:53:37 expired
dist-c8-build-58021-12324 2020-10-30 01:11:08 expired
dist-c8-build-58017-12324 2020-10-30 00:54:47 expired
dist-c8-build-58013-12324 2020-10-29 21:45:19 expired
dist-c8-build-57976-12324 2020-10-29 21:15:56 expired
dist-c8-build-57972-12324 2020-10-29 20:34:12 expired