Sun, 23 Jan 2022 09:24:23 UTC

Information for RPM clippy-1.54.0-2.module_el8.5.0+910+9ca45234.i686.rpm

ID365844
Nameclippy
Version1.54.0
Release2.module_el8.5.0+910+9ca45234
Epoch
Archi686
SummaryLints to catch common mistakes and improve your Rust code
DescriptionA collection of lints to catch common mistakes and improve your Rust code.
Build Time2021-08-27 21:18:13 GMT
Size2241924
7dd019f75b2129ecb310ec9c1803df64
License(ASL 2.0 or MIT) and (BSD and MIT)
Buildrootmodule-rust-toolset-rhel8-8050020210827194040-f73640c0-build-75949-26552
Provides
clippy = 1.54.0-2.module_el8.5.0+910+9ca45234
clippy(x86-32) = 1.54.0-2.module_el8.5.0+910+9ca45234
clippy-preview = 1.54.0-2.module_el8.5.0+910+9ca45234
Obsoletes
clippy-preview <= 0.0.212
Conflicts No Conflicts
Requires
cargo
ld-linux.so.2
ld-linux.so.2(GLIBC_2.3)
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.15)
libc.so.6(GLIBC_2.18)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.4)
libc.so.6(GLIBC_2.28)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.9)
libdl.so.2
libdl.so.2(GLIBC_2.0)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libgcc_s.so.1(GCC_3.3)
libgcc_s.so.1(GCC_4.2.0)
libm.so.6
libm.so.6(GLIBC_2.0)
libm.so.6(GLIBC_2.1)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2)
libpthread.so.0(GLIBC_2.2.3)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
rust(x86-32) = 1.54.0-2.module_el8.5.0+910+9ca45234
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 13 of 13
Name ascending sort Size
/usr/bin/cargo-clippy387324
/usr/bin/clippy-driver6659568
/usr/lib/.build-id0
/usr/lib/.build-id/330
/usr/lib/.build-id/33/50488673a90812210f7c7e5ee31fd543f42ad633
/usr/lib/.build-id/fd0
/usr/lib/.build-id/fd/c595bdb5c9be35e324f97e6e5384abe23e6dc532
/usr/share/doc/clippy0
/usr/share/doc/clippy/CHANGELOG.md163109
/usr/share/doc/clippy/README.md8979
/usr/share/licenses/clippy0
/usr/share/licenses/clippy/LICENSE-APACHE10852
/usr/share/licenses/clippy/LICENSE-MIT1089
Component of No Buildroots