Mon, 17 Jan 2022 11:06:41 UTC

Information for RPM ruby-devel-2.7.3-136.module_el8.5.0+813+054ec265.x86_64.rpm

ID324530
Nameruby-devel
Version2.7.3
Release136.module_el8.5.0+813+054ec265
Epoch
Archx86_64
SummaryA Ruby development environment
DescriptionHeader files and libraries for building an extension library for the Ruby or an application embedding Ruby.
Build Time2021-05-27 16:07:32 GMT
Size266642
b31c953a49714a8b0abfbb93241363ed
License(Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD
Buildrootmodule-ruby-2.7-8050020210527153100-b4937e53-build-71024-21485
Provides
pkgconfig(ruby) = 2.7.3
ruby-devel = 2.7.3-136.module_el8.5.0+813+054ec265
ruby-devel(x86-64) = 2.7.3-136.module_el8.5.0+813+054ec265
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
/usr/bin/pkg-config
libruby.so.2.7()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
ruby(x86-64) = 2.7.3-136.module_el8.5.0+813+054ec265
rubygems
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 43 of 43
Name ascending sort Size
/usr/include/rb_mjit_min_header-2.7.3-x86_64.h1031582
/usr/include/rb_mjit_min_header-2.7.3.h1359
/usr/include/ruby0
/usr/include/ruby.h868
/usr/include/ruby/assert.h1514
/usr/include/ruby/backward0
/usr/include/ruby/backward.h2307
/usr/include/ruby/backward/classext.h501
/usr/include/ruby/backward/cxxanyargs.hpp16361
/usr/include/ruby/backward/rubyio.h191
/usr/include/ruby/backward/rubysig.h895
/usr/include/ruby/backward/st.h193
/usr/include/ruby/backward/util.h203
/usr/include/ruby/config-x86_64.h13379
/usr/include/ruby/config.h1215
/usr/include/ruby/debug.h4428
/usr/include/ruby/defines.h13251
/usr/include/ruby/digest.h1512
/usr/include/ruby/encoding.h18208
/usr/include/ruby/intern.h58587
/usr/include/ruby/io.h5303
/usr/include/ruby/missing.h5411
/usr/include/ruby/onigmo.h44658
/usr/include/ruby/oniguruma.h262
/usr/include/ruby/re.h1436
/usr/include/ruby/regex.h777
/usr/include/ruby/ruby.h99415
/usr/include/ruby/st.h7564
/usr/include/ruby/subst.h374
/usr/include/ruby/thread.h1347
/usr/include/ruby/thread_native.h1333
/usr/include/ruby/util.h1888
/usr/include/ruby/version.h1853
/usr/include/ruby/vm.h1559
/usr/lib/rpm/macros.d/macros.ruby989
/usr/lib64/libruby.so16
/usr/lib64/pkgconfig/ruby.pc1836
/usr/share/licenses/ruby-devel0
/usr/share/licenses/ruby-devel/BSDL1282
/usr/share/licenses/ruby-devel/COPYING2427
/usr/share/licenses/ruby-devel/COPYING.ja2558
/usr/share/licenses/ruby-devel/GPL18092
/usr/share/licenses/ruby-devel/LEGAL39209
Component of No Buildroots