Sat, 26 Nov 2022 08:35:00 UTC

Information for RPM nodejs-1:12.21.0-1.module_el8.3.0+718+96bc7fec.x86_64.rpm

ID294284
Namenodejs
Version12.21.0
Release1.module_el8.3.0+718+96bc7fec
Epoch1
Archx86_64
SummaryJavaScript runtime
DescriptionNode.js is a platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications. Node.js uses an event-driven, non-blocking I/O model that makes it lightweight and efficient, perfect for data-intensive real-time applications that run across distributed devices.
Build Time2021-03-05 00:20:40 GMT
Size10612511
7f4e925778e1b7b5a0dbb19cdb5baace
LicenseMIT and ASL 2.0 and ISC and BSD
Buildrootmodule-nodejs-12-8030020210304194546-30b713e6-build-66804-18567
Provides
bundled(c-ares) = 1.16.1
bundled(histogram) = 0.9.7
bundled(http-parser) = 2.9.4
bundled(icu) = 67.1
bundled(libuv) = 1.40.0
bundled(llhttp) = 2.1.3
bundled(nghttp2) = 1.41.0
bundled(uvwasi) = 0.0.11
bundled(v8) = 7.8.279.23
nodejs = 1:12.21.0-1.module_el8.3.0+718+96bc7fec
nodejs(abi) = 12.21
nodejs(abi12) = 12.21
nodejs(engine) = 12.21.0
nodejs(v8-abi) = 7.8
nodejs(v8-abi7) = 7.8
nodejs(x86-64) = 1:12.21.0-1.module_el8.3.0+718+96bc7fec
nodejs-punycode = 2.1.0
npm(punycode) = 2.1.0
Obsoletes No Obsoletes
Conflicts
node <= 0.3.2-12
Requires
/bin/sh
ca-certificates
libbrotlidec.so.1()(64bit)
libbrotlienc.so.1()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.10)(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.15)(64bit)
libc.so.6(GLIBC_2.16)(64bit)
libc.so.6(GLIBC_2.17)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.28)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.2)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.6)(64bit)
libc.so.6(GLIBC_2.7)(64bit)
libc.so.6(GLIBC_2.9)(64bit)
libcrypto.so.1.1()(64bit)
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit)
libcrypto.so.1.1(OPENSSL_1_1_1)(64bit)
libcrypto.so.1.1(OPENSSL_1_1_1b)(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libgcc_s.so.1(GCC_3.4)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libpthread.so.0(GLIBC_2.3.2)(64bit)
libpthread.so.0(GLIBC_2.3.3)(64bit)
libssl.so.1.1()(64bit)
libssl.so.1.1(OPENSSL_1_1_0)(64bit)
libssl.so.1.1(OPENSSL_1_1_1)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(CXXABI_1.3.5)(64bit)
libstdc++.so.6(CXXABI_1.3.8)(64bit)
libstdc++.so.6(CXXABI_1.3.9)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
libstdc++.so.6(GLIBCXX_3.4.18)(64bit)
libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libz.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Recommends
nodejs-full-i18n(x86-64) = 1:12.21.0-1.module_el8.3.0+718+96bc7fec
npm >= 1:6.14.11-1.12.21.0.1.module_el8.3.0+718+96bc7fec
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 20 of 20
Name ascending sort Size
/usr/bin/node37842152
/usr/lib/.build-id0
/usr/lib/.build-id/f50
/usr/lib/.build-id/f5/720ece93fe8136613f5e4e14c8634a61dd49c124
/usr/lib/node_modules0
/usr/lib/rpm/fileattrs/nodejs_native.attr119
/usr/lib/rpm/nodejs_native.req70
/usr/share/doc/nodejs0
/usr/share/doc/nodejs/AUTHORS118892
/usr/share/doc/nodejs/CHANGELOG.md54013
/usr/share/doc/nodejs/GOVERNANCE.md7155
/usr/share/doc/nodejs/README.md28766
/usr/share/doc/nodejs/onboarding.md13168
/usr/share/licenses/nodejs0
/usr/share/licenses/nodejs/LICENSE81255
/usr/share/man/man1/node.1.gz6940
/usr/share/node0
/usr/share/systemtap0
/usr/share/systemtap/tapset0
/usr/share/systemtap/tapset/node.stp3495
Component of No Buildroots