Fri, 26 Feb 2021 05:25:38 UTC

Information for RPM libffi-3.1-22.el8.aarch64.rpm

ID169735
Namelibffi
Version3.1
Release22.el8
Epoch
Archaarch64
SummaryA portable foreign function interface library
DescriptionCompilers for high level languages generate code that follow certain conventions. These conventions are necessary, in part, for separate compilation to work. One such convention is the "calling convention". The calling convention is a set of assumptions made by the compiler about where function arguments will be found on entry to a function. A calling convention also specifies where the return value for a function is found. Some programs may not know at the time of compilation what arguments are to be passed to a function. For instance, an interpreter may be told at run-time about the number and types of arguments used to call a given function. `Libffi' can be used in such programs to provide a bridge from the interpreter program to compiled code. The `libffi' library provides a portable, high level programming interface to various calling conventions. This allows a programmer to call any function specified by a call interface description at run time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language. The `libffi' library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. A layer must exist above `libffi' that handles type conversions for values passed between the two languages.
Build Time2020-06-15 17:03:21 GMT
Size36012
e39255916d23b3943a817c301edacc38
LicenseMIT
Buildrootdist-c8-stream-build-47614-8451
Provides
libffi = 3.1-22.el8
libffi(aarch-64) = 3.1-22.el8
libffi.so.6()(64bit)
Obsoletes No Obsoletes
Conflicts No Conflicts
Requires
ld-linux-aarch64.so.1()(64bit)
ld-linux-aarch64.so.1(GLIBC_2.17)(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.17)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 9 of 9
Name ascending sort Size
/usr/lib/.build-id0
/usr/lib/.build-id/f20
/usr/lib/.build-id/f2/94a7861d1d4881977032345d0a4fc7f04dbf8a37
/usr/lib64/libffi.so.615
/usr/lib64/libffi.so.6.0.269504
/usr/share/doc/libffi0
/usr/share/doc/libffi/README15464
/usr/share/licenses/libffi0
/usr/share/licenses/libffi/LICENSE1132
Component of
Page:
1 through 50 of 2382 >>>
Buildroot descending sort Created State
dist-c8-updates-build-66461-18327 2021-02-25 17:22:01 expired
dist-c8-stream-build-66447-18320 2021-02-25 07:02:23 expired
dist-c8-stream-build-66442-18320 2021-02-25 07:02:02 expired
dist-c8-stream-build-66427-18306 2021-02-25 01:02:12 expired
dist-c8-stream-build-66415-18292 2021-02-24 16:13:05 expired
dist-c8_3-updates-build-66409-18244 2021-02-24 15:49:49 expired
dist-c8_3-updates-build-66406-18244 2021-02-24 15:45:31 expired
dist-c8-stream-build-66392-18268 2021-02-24 07:03:04 expired
dist-c8-stream-build-66390-18268 2021-02-24 07:03:00 expired
dist-c8-stream-build-66382-18268 2021-02-24 07:02:38 expired
dist-c8-stream-build-66380-18268 2021-02-24 07:02:35 expired
dist-c8-stream-build-66375-18268 2021-02-24 07:02:16 expired
dist-c8-stream-build-66363-18263 2021-02-24 05:03:30 expired
dist-c8-stream-build-66358-18239 2021-02-24 04:40:07 expired
dist-c8-stream-build-66353-18239 2021-02-24 04:32:34 expired
dist-c8_3-updates-build-66343-18185 2021-02-23 22:47:37 expired
dist-c8-stream-build-66301-18212 2021-02-23 07:03:52 expired
dist-c8-stream-build-66299-18212 2021-02-23 07:03:36 expired
dist-c8-stream-build-66287-18212 2021-02-23 07:02:29 expired
dist-c8-stream-build-66284-18212 2021-02-23 07:02:20 expired
dist-c8-stream-build-66283-18212 2021-02-23 07:02:13 expired
dist-c8-stream-build-66282-18212 2021-02-23 07:02:09 expired
dist-c8-stream-build-66279-18212 2021-02-23 07:02:05 expired
dist-c8-stream-build-66275-18212 2021-02-23 07:02:03 expired
dist-c8-build-66261-18013 2021-02-23 05:42:54 expired
dist-c8-build-66252-18013 2021-02-23 04:37:24 expired
dist-c8-build-66249-18013 2021-02-23 04:20:41 expired
dist-c8-build-66246-18013 2021-02-23 03:18:45 expired
dist-c8-build-66244-18013 2021-02-23 01:42:49 expired
dist-c8-build-66241-18013 2021-02-23 00:43:41 expired
dist-c8-stream-build-66177-18194 2021-02-22 21:36:55 expired
dist-c8_3-updates-build-66155-18151 2021-02-22 15:57:27 expired
dist-c8-stream-build-66150-18166 2021-02-22 15:35:43 expired
dist-c8-stream-build-66146-18136 2021-02-22 15:02:34 expired
dist-c8-stream-build-66139-18136 2021-02-22 15:02:14 expired
dist-c8-stream-build-66116-18060 2021-02-22 07:02:22 expired
dist-c8-stream-build-66115-18060 2021-02-22 07:02:19 expired
dist-c8_3-updates-build-65935-18015 2021-02-22 03:22:11 expired
dist-c8_3-updates-build-65931-18015 2021-02-22 03:18:24 expired
dist-c8-stream-build-65910-17997 2021-02-21 05:02:42 expired
dist-c8-stream-build-65896-17987 2021-02-21 01:02:34 expired
dist-c8-stream-build-65876-17973 2021-02-20 07:03:06 expired
dist-c8-stream-build-65874-17973 2021-02-20 07:03:03 expired
dist-c8-stream-build-65872-17973 2021-02-20 07:02:59 expired
dist-c8-stream-build-65871-17973 2021-02-20 07:02:57 expired
dist-c8-stream-build-65863-17973 2021-02-20 07:02:23 expired
dist-c8-stream-build-65852-17968 2021-02-20 05:02:33 expired
dist-c8-stream-build-65830-17946 2021-02-19 09:06:33 expired
dist-c8-stream-build-65825-17946 2021-02-19 09:06:06 expired
dist-c8-stream-build-65818-17946 2021-02-19 09:04:33 expired