Fri, 18 Jun 2021 01:36:39 UTC

Information for RPM clippy-1.34.2-1.el8.i686.rpm

ID75722
Nameclippy
Version1.34.2
Release1.el8
Epoch
Archi686
SummaryLints to catch common mistakes and improve your Rust code
DescriptionA collection of lints to catch common mistakes and improve your Rust code.
Build Time2019-10-10 03:33:54 GMT
Size1714124
1b0406acf3f6e5952fb15f804e8d5f44
License(ASL 2.0 or MIT) and (BSD and MIT)
Buildrootdist-c8-rust-bootstrap-build-25512-2075
Provides
clippy = 1.34.2-1.el8
clippy(x86-32) = 1.34.2-1.el8
clippy-preview = 1.34.2-1.el8
Obsoletes
clippy-preview <= 0.0.212
Conflicts No Conflicts
Requires
cargo
ld-linux.so.2
ld-linux.so.2(GLIBC_2.3)
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.15)
libc.so.6(GLIBC_2.18)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.2.4)
libc.so.6(GLIBC_2.28)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libdl.so.2
libdl.so.2(GLIBC_2.0)
libgcc_s.so.1
libgcc_s.so.1(GCC_3.0)
libgcc_s.so.1(GCC_3.3)
libgcc_s.so.1(GCC_4.2.0)
libm.so.6
libm.so.6(GLIBC_2.0)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2)
libpthread.so.0(GLIBC_2.2.3)
libpthread.so.0(GLIBC_2.3.2)
libpthread.so.0(GLIBC_2.3.3)
librt.so.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)
rust(x86-32) = 1.34.2-1.el8
Recommends No Recommends
Suggests No Suggests
Supplements No Supplements
Enhances No Enhances
Files
1 through 12 of 12
Name Size ascending sort
/usr/lib/.build-id0
/usr/lib/.build-id/160
/usr/share/doc/clippy0
/usr/share/licenses/clippy0
/usr/lib/.build-id/f5/3e02c773026d1294a42e513f743ac6c8d40a3b32
/usr/lib/.build-id/16/02b6cbf20d31d48c916881faaec099a4dc133933
/usr/share/licenses/clippy/LICENSE-MIT1023
/usr/share/doc/clippy/README.md6320
/usr/share/licenses/clippy/LICENSE-APACHE10847
/usr/share/doc/clippy/CHANGELOG.md55667
/usr/bin/cargo-clippy306704
/usr/bin/clippy-driver5900464
Component of No Buildroots